Knutmeg and Anne (and any others who use it:) there is a vulnerability in Movable Type 2.64 which spammers can take advantage of. You can fix it by going here and getting the patch. Pretty easy upgrade this time — just have to replace one file in the CGI folder.